目前分類:CCNA (16)

瀏覽方式: 標題列表 簡短摘要

VTP是一種讓多台Switch可自動同步VLAN設定的通訊協定,目的是要管理整個網路環境的VLAN,維持一致性,我們可以新增、刪除、重新命名VLAN,然後將設定同步到VTP網域中其他Switch

Tips.jpg
VTPCisco的專利,所以網路中的Switch是使用CiscoSwitch才能使用VTP的功能。

VTP Mode
Server Mode
:可新增、刪除、修改VLAN,並同步更新到網域內的VTP Client,設定檔存放於NVRam

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

Switch切完VLAN後使得每個VLAN無法相互連線,若想要在每個VLAN的設備還可以相互連線還需要用使用到Router做路由的動作,因每個VLAN都屬於不同的網段,所以在Router上就需要分割子介面,才可讓所有的VLAN可以相互連線囉!

vlan route.png

vlan 10 網段為 192.168.10.0/24
vlan 20 網段為 192.168.20.0/24
vlan 30 網段為 192.168.30.0/24

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

VLAN(Virtual Local Area Network)虛擬區域網路,是以邏輯連線取代區域網路所定義的實體連線,VLAN提供了邏輯分割區域網路的方法來切割LAN,也可控制LAN的大小,讓管理時更加有彈性。

Access Port & Trunk Port
每個Switch Port有兩種運作模式,一種是Access Mode,另一種是Trunk Mode,當設定為Access Mode時該Port只能指派給一個VLAN,也只允許所屬VLAN的封包通過,如果是Trunk Port,則允許任何VLAN封包通過(在預設情況下)。

查看VLAN狀態:show vlan brief

Switch#show vlan brief                 #先查看目前VLAN狀態

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active   

建立VLAN

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

DHCP 是靠廣播(Broadcast)傳送的,如果 DHCP Server 與 DHCP Client 在不同一個網段,Client就無法配發到IP了,這時候可以使用 DHCP Relay (或稱為 IP Helper),傳送DHCP Client的廣播到DHCP Server以能將IP配發到Client。

dhcp relay.JPG

建立DHCP Pool

R1(config)#ip dhcp pool pool1                                     建立位址儲備池,並命名為pool1
R1(dhcp-config)#network 192.168.10.0 255.255.255.0                指定要分配的IP範圍
R1(dhcp-config)#default-router 192.168.10.254                     設定Pool1之預設閘道
R1(dhcp-config)#dns-server 8.8.8.8                                設定DNS
R1(dhcp-config)#exit                                              返回全域模式
R1(config)#ip dhcp excluded-address 192.168.10.200 192.168.10.254 指定192.168.10.200 ~ 192.168.10.254不配發

設定路由
由於在R1的路由表中並沒有192.168.10.0/24網段,所以必需要此網段加入路由表中

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

啟用port-security
啟用port-security前需先將switchport mode由dynimic改為access,若無更改則會出現錯誤訊息。

Switch(config)#interface FastEthernet 0/1                 進入FastEthernet0/1介面設定
Switch(config-if)#switchport port-security                啟用port-secruity
Command rejected: FastEthernet0/1 is a dynamic port.      啟用失敗
Switch(config-if)#switchport mode access                  將switchport mode更改為存取埠(access)模式
Switch(config-if)#switchport port-security                啟用port-secruity
更改完後FastEthernet0/1介面即啟用port-security

查看port-security狀態

Switch#show port-security interface fastEthernet 0/1    查看FastEthernet0/1介面port-security設定
Port Security              : Enabled                    Port Security已啟用
Port Status                : Secure-down                因尚未連接設備所以是Secure-down
Violation Mode             : Shutdown
Aging Time                 : 0 mins
Aging Type                 : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses      : 1
Total MAC Addresses        : 0
Configured MAC Addresses   : 0
Sticky MAC Addresses       : 0
Last Source Address:Vlan   : 0000.0000.0000:0          因尚未連接設也未記錄MAC Address
Security Violation Count   : 0

在FastEthernet0/1接上設備後再查看port-security狀態

Switch#show port-security interface fastEthernet 0/1 查看FastEthernet0/1介面port-security設定
Port Security              : Enabled
Port Status                : Secure-up               未連接設備後狀況改為Secure-up
Violation Mode             : Shutdown
Aging Time                 : 0 mins
Aging Type                 : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses      : 1
Total MAC Addresses        : 1
Configured MAC Addresses   : 0
Sticky MAC Addresses       : 0
Last Source Address:Vlan   : 00E0.8FD0.9C17:1        Mac Address也被記錄下來了
Security Violation Count   : 0

手動輸入綁定Mac address

小必 發表在 痞客邦 留言(0) 人氣()

ip route.JPG

設定靜態路由(Static Route)
(config)#ip route 目的網路 遮罩 下站位址或離開介面
以R1為例
(config)#ip route 192.168.40.0 255.255.255.0 192.168.40.253        將192.168.40.0網段之封包交由192.168.40.253傳送

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

(config)#ip dhcp pool pool1                                               建立位址儲備池,並命名為pool1
(dhcp-config)#network 10.0.0.0 255.255.255.0                  指定要分配的IP範圍(10.0.0.0為Network ID)
(dhcp-config)#default-router 10.0.0.254                            設定預設閘道
(dhcp-config)#dns-server 8.8.8.8                                        設定DNS
(dhcp-config)#exit                                                              回到全域模式

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

用戶端(設定自動取得IP)

  1. 網路上沒有DHCP伺服器時
    • 剛開機時的IP:0.0.0.0
    • 自動使用APIPA IP(169.254.x.x)
  2. 網路上有DHCP伺服器時
    • 用戶端發出DHCP探索(廣播)
    • DHCP伺服器保留一個IP準備給用戶
    • 發出DHCP回覆(廣播)
  3. 用戶端發出DHCP要求(廣播)
    • 沒被要求的DHCP釋放IP
  4. DHCP伺服器發出DHCP確認

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

非對稱式(asymmetric)加密

  1. 伺服器產生兩把key
  1. 公開key:可在網路上傳遞
  2. 私密key:伺服器獨自保管
  1. 非對稱式加密用途
  1. 資料加密:用公開key加密;用私密key解密
  2. 確認資料完整性(數位簽章):用私密key加密,用公開key解密
  1. 非對稱式加密:加解密用不同key
  2. 如何確認伺服器公開key的真偽
  1. 使用憑證授權單位
  2. 確認資料完整性

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

要啟用SSH需完成3個設定

1.設定本機帳號
(config)#username cisco password ccna   建立帳號cisco密碼nnca(密碼未加密)
(config)#username cisco secret ccna         建立帳號cisco1密碼nnca(密碼加密)
同一帳號僅可選一種方式設定密碼

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

設定Console登入密碼
(Config)#line console 0             由全域模式進入line模式
(Config-line)#password ccna    將密碼為ccna
(Config-line)#login                   啟用密碼

取消登入密碼

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

TFTP是一種簡單型FTP服務,和FTP一樣可作為檔案傳輸用,FTP是使用TCP協定傳輸,而TFTP是使用UDP,因此TFTP不需經過驗證,通常用於網路設備之間的檔案傳輸,我們可使用TFTP更新網路設備的韌體(Firmware)或設定。

在PacketTracert新增TFTP Server

pt-server.JPG

在左下角之"End Device"選擇"Server PT",設定好IP後和R1連線即可。

tftp.JPG

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

Cisco_Bootup-1.jpg

 

  1. 當Router/Switch通電後會先做POST(Power on Self Test)
  2. Bootstrap
    尋找IOS檔案
  3. Flash
    開機區程式儲存於唯讀記憶體 ROM 中,它會到 Flash Memory 去尋找 Cisco IOS 軟體來載入,若找不到IOS檔案,則執行mini IOS,進入ROM Monitor模式
  4. NVRAM(Non-Violatile Random Access Memory)
文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

之前學CCNA時每次遇到計算遮罩都讓我很頭大
今天上課學到的再配合同學提供的方法真的讓我解決了煩腦已久的問題了
今天一定要把這方法記錄起來
避免下次要用時忘了就麻煩了 


我們常會在查看IP時看到像這樣的表示法:192.168.3.12/24

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

xxxx : xxxx : xxxx : xxxx : xxxx : xxxx : xxxx : xxxx
Network ID Host

假設一MAC為: 00:10:AB:23:45:67
使用IPv6 EUI-64格式轉換後之IPv6 IP為: 0210 : ABFF : FE23 : 4567
轉換過程:

  1. 在MAC第6個數字後加上FFFE  => ABFF : FE23
  2. 將第2個數字(U/L bit)以16進位展開為:0000 0000,將第7個bit做補數運算,即0變成1,1變成0 => 0000 0010
    U/L bit為0表示:全球統一管理

小必 發表在 痞客邦 留言(0) 人氣()

IP v4

私有IP位址(Private IP):
Class A 10.0.0.0/8 (1段)

Class B 172.16.0.0/16 ~ 172.31.0.0/16 (16段)

Class C 192.168.0.0/24 ~ 192.168.255.0/24 (256段)

文章標籤

小必 發表在 痞客邦 留言(0) 人氣()

您尚未登入,將以訪客身份留言。亦可以上方服務帳號登入留言

請輸入暱稱 ( 最多顯示 6 個中文字元 )

請輸入標題 ( 最多顯示 9 個中文字元 )

請輸入內容 ( 最多 140 個中文字元 )

請輸入左方認證碼:

看不懂,換張圖

請輸入驗證碼